Problem downloading query results

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem downloading query results

Ygor Cardoso
Hello there,

I'm doing a CONSTRUCT query to my repository through the openrdf-workbench interface; it shows the results correctly but whenever I try to click the download button and export the results to any format it allways return a file with no results and the following content:

<?xml version='1.0' encoding='utf-8'?>
<?xml-stylesheet type='text/xsl' href='/openrdf-workbench/transformations/query.xsl'?>
  <head>
    <link href='info'/>
    <link href='namespaces'/>
  </head>
</sparql>

I have tried this with chrome, firefox and IE, and it always yelds the same result. Can anyone help?

Thanks in advance,

Regards,
Ygor Cardoso

------------------------------------------------------------------------------


_______________________________________________
Sesame-general mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/sesame-general
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem downloading query results

Mark
This post has NOT been accepted by the mailing list yet.
I encounter this problem and still stuck with it. I am looking for help.

Best
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem downloading query results

pedd
In reply to this post by Ygor Cardoso
I have the same problem, but interestingly only with one particular CONSTRUCT query (so far). I have another CONSTRUCT query where the results can be downloaded. I'm guessing your symptom is the same i.e. the query runs, what you see in the SESAME Workbench page visually looks normal, but the file downloaded just contains an XML error file. I wonder if the head section
 <head><link href='info'/><link href='namespaces'/></head>
is a clue? Is there something wrong with the namespaces?
I'm going to continue experimenting, trying to find the unique difference between my two queries - there must be a reason somewhere - length of query? memory limitation?...
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem downloading query results

pedd
In reply to this post by Ygor Cardoso
Apparently this forum is no  longer active - I will bring the issue up on the Google Group. Any way, here is a big clue:

This code below works and the results are downloadable:

PREFIX need:<http://eidc.ceh.ac.uk/onto/needcore#>
CONSTRUCT {
  ?a need:hasSubject ?s . 
}
WHERE
 {
  ?a need:hasSubject ?s . 
}
ORDER by ?a

I can trigger the problem simply by inserting a block of comment lines as follows:

PREFIX need:<http://eidc.ceh.ac.uk/onto/needcore#>
CONSTRUCT {
  ?a need:hasSubject ?s . 
}
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
#########################################################
WHERE
 {
  ?a need:hasSubject ?s . 
}
ORDER by ?a

The version padded with comments works just fine, but the results are not downloadable.

In other words, it is entirely due to the length of the query (in my case). When the query is too long, SESAME pops up a message warning you that your query will not be saved. That is when the bug kicks in.
Loading...